Courier API error: Missing mandatory data in 'Service' 'PSD'

Modified on Mon, 29 Sep at 11:54 AM

Cause
This error occurs when no email address is present on the order, and MyGLS requires an email address for PSD service (locker delivery). 


If email addresses are not collected at checkout, MyGLS validation fails during label creation or shipment submission.


Solutions

  1. Add the email manually on the specific order.
  2. Enable auto-fill to insert a placeholder (dummy) email when missing.

Check here the settings to add automatically a fictive email address

https://xconnector.freshdesk.com/support/solutions/articles/103000320734-automatically-add-an-email-address-to-the-order-when-the-email-field-is-empty

Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select at least one of the reasons

Feedback sent

We appreciate your effort and will try to fix the article